ServiceBench Production US - Degraded Performance

Incident Report for ServiceBench

Resolved

This incident has been resolved.
Posted Aug 26, 2026 - 13:38 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 26, 2026 - 13:19 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 26, 2026 - 13:12 EDT

Investigating

Users may experience issues using the application. We are investigating the issue to identify the cause of the problem.
Posted Aug 26, 2026 - 12:38 EDT
This incident affected: Servicebench US Production (www.servicebench.com, Servicebench CRM Web Service Calls, Servicebench External Third Party Web Calls, mft.servicebench.com) and ServiceBench US Prod Mobile (ServiceBench US Prod Mobile App).